vSAN -- When attempting to remove Disk/Disk Group: "General VSAN error: Another vSAN decommission operation is already in progress. Retry operation"
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vSAN -- When attempting to remove Disk/Disk Group: "General VSAN error: Another vSAN decommission operation is already in progress. Retry operation"

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Article ID: 394108

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Updated On:

Products

VMware vSAN VMware vSAN 7.x VMware vSAN 8.x

Issue/Introduction

One or both of the following Symptoms apply:
 
  • When trying to remove Disk or Disk Group from the Web Client:
 
 
  • When trying to remove the Disk or Disk Group via CLI (by logging into the Host via SSH/Putty):
"VsanInfoImpl: Failed to get VsanInfo operation lock for diskOpLock, an operation is currently in progress(locked pid: 0), error: /tmp/ .vsanDiskOpLock.lock.LOCK: timeout waiting for lock after xx seconds. Lock is currently held by process ##### ()
Errors: Unable to remove device: 
Failed to get VsanInfo operation lock for diskOpLock, an operation is currently in progress(locked pid: 0), error: /tmp/ .vsanDiskOpLock.lock.LOCK: timeout waiting for lock after xx seconds. Lock is currently held by process ##### () "
 
Example: 

Environment

vSAN 7.x
vSAN 8.x

Cause

When checking the status of the vsanmgmtd service via CLI (SSH/Putty Session into the Host), an issue with the process can be determined: 
 
 
When attempting to stop the process the following error is received:
 

Wait for ###### termination timed out

sh: can't kill pid ######: No such process

Failed to terminate ######

 
 
The attempt to terminate the still running  process failed with:
 
sh: can't kill pid ######: No such process

 

Example:

Resolution

The Host needs to be rebooted.

Due to the issue with the vsanmgmtd service as described above, the Host cannot be put in Maintenance Mode for the reboot.

In order to prepare for this reboot, follow these steps:

1.) For discussing the impact of the Host reboot on vSAN Cluster, please open a Ticket with VMware by Broadcom Support
2.) As pro-active measure: Ensure that valid Backups of the VMs exist
3.) VMs running on the affected Host need to be shutdown or manually migrated off that Host prior initiating the reboot

Additional Information