vSAN modules fail to display any info in vSphere Client with an error "Unable to retrieve/query information/configuration. Check vSphere Client logs for details"
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vSAN modules fail to display any info in vSphere Client with an error "Unable to retrieve/query information/configuration. Check vSphere Client logs for details"

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Article ID: 394097

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Updated On:

Products

VMware vSAN 7.x VMware vSAN 8.x VMware vCenter Server 7.0 VMware vCenter Server 8.0

Issue/Introduction

After upgrading the VCenter appliance as part of the VCF upgrade vSAN plugin modules in the vSphere Client fail to load.
vSAN modules show the error 'Unable to query vSAN health information. Check vSphere Client logs for details.' or "Unable to retrieve the cluster configuration. Check vSphere Client logs for details."

Environment

VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x

Cause

During the upgrade of the vCenter Server, it is possible to have the same vCenter Server registered more than once to the Single Sign-On (SSO) causing  vCenter server service/plugins to become inaccessible .

Resolution


Take a offline snapshot of the VCenter and follow the KB  Using the 'lsdoctor' Tool to rebuild the service registrations, followed by a restart of the VCenter services to resolve the issue.