VM Backup fails from Specific Host due to missing datastore
search cancel

VM Backup fails from Specific Host due to missing datastore

book

Article ID: 394073

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Veeam backup appliance reports backup failure

Environment

vSphere ESXi 7.x

vSphere ESXi 8.x

Cause

Datastore Unavailable: Not Mounted or Missing from ESXi Host

Resolution

Resolution:

To resolve the issue, ensure that the missing datastore—hosting the virtual machine—is mounted or rescanned on the isolated ESXi host.

  • Steps to Mount the Datastore:
    1. Log in to the vSphere Client.

    2. Navigate to Storage and locate the required datastore.

    3. Right-click on the datastore and choose one of the following options (based on the datastore type):

      • Mount Datastore

      • Mount Datastore on Additional Hosts

    4. In the prompt, select the ESXi host(s) that need access to the datastore, then click OK.

  • To Verify Datastore Access:
    1. Select the datastore in the vSphere Client.

    2. Click on the Hosts tab to view a list of all ESXi hosts that currently have access to the datastore.

Note: If mounting the datastore fails with the error: "The name 'Datastore' already exists"
- This indicates that the datastore is already mounted on the ESXi host but is not visible in the vSphere Client UI or inventory.
- In such cases, perform a rescan of the storage adapters at the host level to refresh the datastore visibility. Refer to steps in KB- Performing a rescan of the storage on an ESXi host, Once the rescan is complete, verify that the datastore appears in the inventory and then retry the snapshot backup operation.