Absent or unknown disk shown in vSAN disk group view after disk replacement
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Absent or unknown disk shown in vSAN disk group view after disk replacement

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Article ID: 393923

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Updated On:

Products

VMware vSAN

Issue/Introduction

After replacing a physical disk in a vSAN disk group, a reference to an absent or unknown disk may be seen in the vSAN disks view in vCenter.

 

In the vSAN disk group view under the vSAN cluster in vCenter, there may be an "Absent vSAN Disk" listed with a health status of "Unknown"

Environment

vSAN

Cause

When a disk is removed, particularly when it has failed, a reference to it may remain in the vSAN database.

Resolution

  1. Place the host into maintenance mode. 
  2. Run this command on the ESXi host that shows the absent/unknown disk.

    esxcli vsan storage list

  3.  In the output, look for a disk with a "CMMDS: false" status. Confirm that the disk ID and Device information show as "Unknown".

       Unknown
       Device: Unknown
       Display Name: Unknown
       Is SSD: false
       VSAN UUID: ########-####-####-####-############
       VSAN Disk Group UUID:
       VSAN Disk Group Name:
       Used by this host: false
       In CMMDS: false
     
  4. Copy the vSAN UUID of the unknown disk from the above output.
  5. Run this command to remove the reference to this disk from vSAN:

    esxcli vsan storage remove -u ########-####-####-####-############
     
  6. Return to vCenter, and confirm that the Absent/Unknown disk is no longer listed under the vSAN disk groups view.