vCenter Server Warning: /storage/log Low on Storage Due to statsmoitor-alarms.log Not Rotating
search cancel

vCenter Server Warning: /storage/log Low on Storage Due to statsmoitor-alarms.log Not Rotating

book

Article ID: 393842

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

After upgrading or monitoring the vCenter Server Appliance (VCSA), users may encounter a warning:

"File system /storage/log is low on storage space"

Upon investigation, the file /storage/log/vmware/statsmon/statsmoitor-alarms.log was found to be large (e.g., 4.4 GB) causing the partition to run out of space. In severe cases, this may also prevent vCenter services such as VPXD from starting.

Environment

vCenter 8.0.3 on build-24322831

Cause

 

  • The log file statsmoitor-alarms.log is not included in vCenter’s default log rotation policies.

  • Without rotation, this file grows indefinitely and can fill the /storage/log partition.

 

Resolution

This is a know issue and Broadcom engineering is aware of this issue. As workaround please follow the steps mentioned below. 

Workaround: Configure log rotation for statsmoitor-alarms.log

  1. SSH to the vCenter as root.

  2. Create a custom logrotate config file:

vi /etc/logrotate.d/statsmon-alarms.lr

Add the following content:

 
 
/var/log/vmware/statsmon/statsmoitor-alarms.log
{ hourly
size 10M
minsize 5M
maxsize 10M
rotate 7
compress
copytruncate
dateext
dateformat -%Y%m%d%H%M%S
missingok
notifempty
}
 
  1. Verify the configuration:

 
cat /etc/logrotate.d/statsmon-alarms.lr
 
  1. Run logrotate manually to test:

 
logrotate -f /etc/logrotate.conf
 
  1. Check rotation has taken place:

 
ls -ltrh /storage/log/vmware/statsmon/

Expected output (sample):

 
-rw-r--r-- 1 root root 472K Apr 9 13:34 statsmoitor-alarms.log-20250409133402.gz
-rw-r--r-- 1 root root 890 Apr 9 13:34 statsmoitor-alarms.log-20250409133409.gz
-rw-r--r-- 1 root root 1.1K Apr 9 13:38 statsmoitor-alarms.log-20250409133811.gz
-rw-r--r-- 1 root root 146K Apr 9 14:29 statsmoitor-alarms.log

 

Additional Information

If vCenter is unresponsive or VPxD fails to start due to disk full:

You may need to clear the log file content to immediately recover disk space:

 
echo "" > /storage/log/vmware/statsmon/statsmoitor-alarms.log

Alternatively, use truncate:

 
truncate -s 0 /storage/log/vmware/statsmon/statsmoitor-alarms.log

⚠️ Warning: Only clear the file if you have confirmed it is safe to do so and no active analysis of the file is required.