Service Manager stops with U00022078 CAPKI Invalid or missing file
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Service Manager stops with U00022078 CAPKI Invalid or missing file

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Article ID: 393837

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

The Service Manager stops right after the start (in this case after a CAU of an associated Agent) with the following kind of errors indicating that one of the two certificate files is missing:

20250409/121520.439 - U00022071 CAPKI Library available.
20250409/121520.440 - U00022078 CAPKI: Invalid or missing 'key' file '/path_to_smgr/bin/ucybsmgr_key.pem'.
20250409/121520.440 - U00022072 CAPKI Library initialization failed.
20250409/121520.440 - U00022002 Automic Service Manager, Version '21.0.12+hf.2.build.1731087520404' ended abnormally.

Indeed, while checking the service manager bin folder where the key and certificate files are created and read from, it's found that only the certificate file can be found, no trace of the key file.

With the previous version, the service manager process continued running even though one of the files was missing.

How can this be solved?

Environment

Service Manager 21.0.12+ and 24.3.0+

Cause

The behavior was changed via DE128800:  Service Manager falsely starts even if CAPKI keys are configured wrongly reporting success in log files but is not accessible later on via service manager dialog.

Before 21.0.12 or 24.3.0, the process would start but it could not be connected to a service manager dialog due to the lack of one of the key or certificate file, from 21.0.12+ and 24.3.0 the process will fail to start and will display the message:

U00022078 CAPKI: Invalid or missing XXX file YYY .

Resolution

Please move or delete the file not displayed in the error (on this case ucybsmgr_certificate.pem) and restart the service manager.

Extract from the documentation:

The ServiceManager generates a new certificate if it cannot find an existing one. In this case, you have to delete the UCYBSMgr_certificate.pem and UCYBSMgr_key.pem files from the .\bin directory of the ServiceManager and restart it. During the startup process, the ServiceManager generates a new private key and certificate.

Additional Information

In case the missing file was ucybsmgr_certificate.pem (certificate), please move or delete the file ucybsmgr_key.pem and restart the service manager.

On some cases, CAPKI installation may be corrupted so it would be needed to reinstall CAPKI