VPC Connectivity Profile dropdown is empty when Activating a Supervisor cluster
search cancel

VPC Connectivity Profile dropdown is empty when Activating a Supervisor cluster

book

Article ID: 393746

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • On the vSphere client, Activate a Supervisor -> Workload Network, the dropdown for VPC Connectivity Profile is not populated
  • It is not possible to proceed as VPC Connectivity Profile is a required field, the error shows "This field is required"

  • On the NSX UI, at least one VPC Connectivity Profile exists under VPCs -> Profiles -> VPC Connectivity Profile

Environment

VCF NSX 9

Cause

The field "default outbound NAT" must be enabled on the VPC Connectivity Profile for it to be available to select during Supervisor cluster creation.
Note, it is only possible to enable "default outbound NAT" when the T0 Gateway is configured with HA Mode Active Standby.

Resolution

If the T0 is Active Standby, enable "default outbound NAT" on the VPC Connectivity Profile and return to the Supervisor configuration page.
If the T0 is Active Active, the T0 must be reconfigured to Active Standby HA mode. Afterwards enable "default outbound NAT" on the VPC Connectivity Profile and return to the Supervisor configuration page.