Cloud Account Data Collection Fails with 'Temporary Failure in Name Resolution' Error in Aria Automation
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Cloud Account Data Collection Fails with 'Temporary Failure in Name Resolution' Error in Aria Automation

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Article ID: 393705

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Aria Automation Cloud Accounts intermittently enter a Warning state, resulting in data collection failures. 

  • The following error can be seen upon accessing the Cloud Account: 

    Data Collection failed
    java.util.concurrent.CompletionException: com.vmware.photon.controller.model.adapters.vsphere.VsphereAdapterException: The connection with vPI endpoint can not be established. Cause: java.net.UnknownHostException: <vCenter name>: Temporary failure in name resolution

  • The nslookup command intermittently failed or timed out with the following error:

    • connection times out; no servers could be reached

  • If there are multiple DNS servers, then maybe only one is having issues. Check each one individually:
    • Check what DNS servers are used:
      • cat /etc/resolv.conf

        nameserver ##.##.##.101
        nameserver ##.##.##.102
    • Check name resolution against each DNS server individually:
      • nslookup vcenter.example.com ##.##.##.101
      • nslookup vcenter.example.com ##.##.##.102

Environment

  • VMware Aria Automation 8.x

Cause

  • Intermittent failures in DNS resolution, specifically caused by a problematic DNS server, result in the Aria Automation nodes being unable to reliably resolve the Cloud Accounts' hostnames.

  • This leads to the "java.net.UnknownHostException: <vCenter name>: Temporary failure in name resolution" error.

Resolution

  1. Identify and remove the problematic DNS server IP address from the /etc/resolv.conf file on all Aria Automation nodes.

  2. Use the following document to update/add DNS in Aria Automation: Update the DNS assignment for VMware Aria Automation

  3. Engage the DNS/internal network teams to investigate and resolve the underlying DNS or network stability issues to prevent future occurrences.

Additional Information

  • Intermittent DNS issues can result in cloud accounts entering a warning state even if services like vCenter or NSX-T are otherwise healthy.

  • Consistent DNS resolution is critical for proper functioning of Aria Automation integrations.

  • Administrators are advised to work with internal DNS/networking teams to ensure stability and remove any failing or unresponsive DNS servers.