NSX Edge status reports error: "Overall status of the edge transport node is DOWN" in NSX Manager UI
search cancel

NSX Edge status reports error: "Overall status of the edge transport node is DOWN" in NSX Manager UI

book

Article ID: 393678

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Edge Post Check failure at the end of the Edge upgrade stage when upgrading from SDDC Manager.
  • Edge Upgrade status shows COMPLETED_WITH_FAILURE after NSX_UPGRADE_STAGE_EDGE_POSTCHECK stage when checking Update Activity.
  • Edge reports status "Overall status of the edge transport node is DOWN"  in NSX Manager UI as shown in the screenshot below:

  • Click on "Error(s)" to view the following message: Overall status of the Edge Transport Node <UUID> is DOWN.

  • However, There are no issues observed with the Edge, as the node status is "Up" and all tunnels are operational.

Environment

VMware NSX

Cause

This is due to a timing/sync issue between when the Upgrade-coordinator invokes post check on the  Edge nodes vs the time when all the agents come back online on the Edge node itself and Management Plane connectivity is fully established.

Resolution

  1. Ensure there are no issues with the Edge node.
  2. As a work around to resolve the issue perform the "Run Post Check" in the NSX Manager to synchronize the Edge node's status