"Error: Unable to Load Group." when modifying newly added AD group
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"Error: Unable to Load Group." when modifying newly added AD group

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Article ID: 393640

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Updated On: 04-08-2025

Products

VMware Aria Suite

Issue/Introduction

  • New groups are not accessible after adding via Access Control
  • You can add the group without issue, but after adding you get an error when you click on edit stating "Error: Unable to Load Group."
  • Looking at the custom role applied it shows no users/groups applied and the users in the group are not showing in the app.
  • You receive the same result with any different AD group that was newly added
  • You are able to successfully edit previously imported. AD groups

Environment

VMware Aria Operations for Logs 8.18.x

Cause

The entry for the domain in the internal Cassandra database is case sensitive.

The AD domain was previously integrated in Aria Operations for Logs using a different character case than the current integration uses.

Resolution

  1. Log in to the primary node as root via SSH or vSphere Console

  2. Log in to the internal Cassandra database
    cqlsh-no-pass
  3. Query the current AD groups from the database
    select domain,name from directory_group where type=0 allow filtering;
  4. Note the character case of the domain used for the AD groups that are editable in the UI

    Example: example.corp or EXAMPLE.CORP or Example.corp

  5. Log in the Aria Operations for Logs UI as an administrative user and navigate to Configuration > Authentication

  6. Click the vertical 3 dots next to Active Directory and select Edit

  7. Update the Default Domain field to use the domain name with the same character class noted in step 4

  8. Provide the Password for the configured integration user

  9. Click TEST CONNECTION and verify Succeeded is receivedthen click SAVE

  10. Navigate to Management > Access Control, import a new AD group, and verify the group can now be edited.