Frequent vSAN "Network latency check" status changes from green to yellow.
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Frequent vSAN "Network latency check" status changes from green to yellow.

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Article ID: 393638

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Updated On:

Products

VMware vSAN

Issue/Introduction

vSAN Network latency alarm "Network latency check" is triggered but goes back to a green state after some time and the latency follows a single host. 

 

 

Environment

VMware vSAN (All Versions)

Cause

"Network latency check" will be triggered by any host with more then 5ms latency on the vSAN network.  When the alert is trigged for a single host, that host should be investigated for networking errors or high vSAN network utilization leading to Slower pings. 

Example

Guest VM utilizing all available bandwidth on host 2 and then migration to host 6 with the "Network latency check" following the Host that owns the Guest VM. 

Host2 

Guest is then is moved to HOST 6 and the "network latency check" follows the guest VM. 

As this guest was reading from the vSAN at 1.4GBs this will saturate the 10gb link for vSAN and can lead to higher network latency during the testing.

Resolution

Work with the Guest owner to determine cause of the high network utilization and correct it if possible. 

Check for other network health items for that could be misconfigured vSAN Skyline Health Check Information. Check the network conditions between the cluster nodes that report any issues.

Also, see: VMware vSAN Diagnostics and Troubleshooting Reference Manual

 

Reference KB 

vSAN Health Service - Network Health - Network Latency Check