Agent Install or Upgrade Fails Due to Failed to Start Service Error[577]
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Agent Install or Upgrade Fails Due to Failed to Start Service Error[577]

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Article ID: 393636

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

During installation or upgrade, the attempt fails with the following seen in the log:

[04-08-2025 11:07:12:163] DisableLSP - WSCSetApplicationCategory succeeded

[04-08-2025 11:07:12:163] DisableLSP - WSCSetApplicationCategory succeeded

[04-08-2025 11:07:12:163] Service[6]: Service State[1:Stopped] Pid[0] ControlsAccepted[00000000] WaitHint[0] ExitCode[0 (1077)] Checkpoint[0] ServiceFlags[00000000] Type[00000010]

[04-08-2025 11:07:12:178] Attempting to start the service[PARITY]
[04-08-2025 11:07:12:631] Service[1]: Failed to start service Error[577]
[04-08-2025 11:07:12:631] Error: Failed to start the service[PARITY], Error[577]

[04-08-2025 11:07:12:631] Service[3]: Closing service handle

Environment

  • App Control Agent: All Supported Versions
  • Microsoft Windows: All Supported Versions

Cause

The issue is related to the InstallShield 2021 version used by the the Agent when being installed on Windows systems with specific operating system hardenings in place:

  • SEHOP Enable: True
  • Heap TerminateOnError: True

Resolution

This is scheduled to be resolved with the release of Agent version 8.10.2, when the installer is upgraded to use InstallShield 2024

Additional Information

This issue was tracked as EPCB-21938.