Synchronization with AD failed and manual synchronization will only remove users in vIDM
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Synchronization with AD failed and manual synchronization will only remove users in vIDM

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Article ID: 393526

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Unable to Synchronize Active Directory (AD).
  • Receive below error when tried to delete the directory.

    Cannot delete config with <uuid> when associated connector instance is joined to domain

Environment

VMware Identity Manager: 3.3.7

Cause

Active Directory (AD) IP address was changed while vIDM had the AD connected with the old IP address.

Resolution

Note: Take a snapshot of a cluster without a memory before proceeding.

1. Check if the appliance is joined to the domain.
    /opt/likewise/bin/domainjoin-cli query 

   The output will look like below if there is no domain attached:
 

2. Remove the appliance from the joined domain if you wish to remove from vIDM UI.
    /opt/likewise/bin/domainjoin-cli leave

3. Remove Active Directory (AD) profile from vIDM UI. Step to follow:
    -- Log in to the vIDM UI using admin credential.
    -- Click on Identity and Access Management on top menu.
    -- Click on AD_Domain
    -- And then, click on Delete Directory button