Symptoms:
Infrastructure Manager frequently disconnects to the primary hub, but probes in the primary hub are functioning and all permanent queues are ok.
In the hub.log the following errors are recorded:
Jan 21 07:32:00:079 [22920] hub: General error on session
Jan 21 07:32:00:079 [22920] hub: Disconnecting queue route for 'baseline_engine.HTCAAPP01.BASELINE_CONFIG' (error 3 on queue)
Jan 21 07:32:00:483 [5680] hub: General error on session
Jan 21 07:32:00:483 [5680] hub: Disconnecting queue route for 'prediction_engine.HTCAAPP01.PREDICTION_CONFIG' (error 3 on queue)
In the Nimsoft Service Controller window on primary hub server, there is no robot information and client connection to primary hub drops.
<Please see attached file for image>
Environment:
UIM server 8.x
Windows Server 2008 R2 sp1
Cause:
The niscache folder under Nimsoft install folder is oversized with more 1.6 million files and more than 300 MB in size. The primary hub performance became degraded and more communication errors for client connections.
Resolution:
Rdp to the desktop of Windows server
Open a command line window and change directory to niscache folder
Delete all files using this command: del /Q *.*
Restart local Nimsoft Service