IM frequently disconnects to hub
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IM frequently disconnects to hub

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Article ID: 39343

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Infrastructure Manager frequently disconnects to the primary hub, but probes in the primary hub are functioning and all permanent queues are ok.

In the hub.log the following errors are recorded:

hub: General error on session
hub: Disconnecting queue route for 'baseline_engine.<hubname>.BASELINE_CONFIG' (error 3 on queue)
hub: General error on session
hub: Disconnecting queue route for 'prediction_engine.<hubname>.PREDICTION_CONFIG' (error 3 on queue)

In the Nimsoft Service Controller window on the Primary hub server, there is no robot information, and the client connection to the Primary hub drops.

Environment

  • Component: UIMHUB  
  • Release: UIM server 8.x
  • Windows Server 2008 R2 sp1

Cause

  • The niscache folder under Nimsoft install folder is oversized with more 1.6 million files and more than 300 MB in size. The primary hub performance became degraded and more communication errors for client connections.

Resolution

  1. RDP to the desktop of the Windows robot/server
  2. Open a command line window and change directory to niscache folder
  3. Delete all files using this command: del /Q *.*
  4. Restart local Nimsoft Service