Latency reported on applications hosted on vSAN OSA datastore
search cancel

Latency reported on applications hosted on vSAN OSA datastore

book

Article ID: 393379

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • Log into guest OS for the affected VM.
  • Launching any application takes longer time than usual.

Environment

VMware vSAN 6.x
VMware vSAN 7.x
VMware vSAN 8.x

Cause

vSAN is designed to work best with 4k aligned I/O (4k, 8k, 16k, 32k, 64k, etc) from guests. When I/O is not aligned to a 4k size, additional I/O operations are required at the vSAN layer before the write can be completed. This adds time (latency) until these operations are completed.

Cause validation:

  • Collect the vSAN I/O Insight instance.


    From the above screenshot it is confirmed that 4K unaligned I/O operations reached up to 50%.

    Refer document to Use vSAN I/O Insight

Resolution

Ensure that the guest operating system and applications are set to use 4k blocks for all I/O operations. Engage your application team/software vendor to ensure the OS/application is using 4k blocks and if not configure the I/O for 4k block size.

Impact/Risks:
Any changes to the guest operating system or application should be discussed with the relevant vendor.