Error when creating a policy in Aria Automation via API - "Policy not supported for creating an existing entry that is waiting for clean up."
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Error when creating a policy in Aria Automation via API - "Policy not supported for creating an existing entry that is waiting for clean up."

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Article ID: 393369

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Symptoms:

  • You may receive this response from the Aria Automation API when you create a new policy:
    {
      "message": "Policy not supported for creating an existing entry that is waiting for clean up.",
      "statusCode": 400,
      "errorCode": 50019
    }

Environment

Aria Automation 8.18.1

Cause

This is because there is another existing policy in Aria Automation that uses this ID.

Resolution

This is the expected behavior,you need to delete the policy first.

After deletion,the policy will remain in a soft-deleted state and won't be removed from the database until all the dependent decisions are removed.

You can check the decisions of the policy in Service Broker -> Content and Policies -> Enforcement.

Search for "lease policy", all results listed are decisions.

Once all these decisions are deleted the policy is physically deleted from the DB and you will be able to create a new one with the same ID.