Rally - Custom Views - Bar Widget inconsistent results .
search cancel

Rally - Custom Views - Bar Widget inconsistent results .

book

Article ID: 393368

calendar_today

Updated On:

Products

Rally SaaS

Issue/Introduction

Users observed that the Bar widget in custom pages does not aggregate data accurately when the project hierarchy is selected

Steps to reproduce the issue:

  1. Create a Custom View.
  2. Add the Bar widget
  3. Set the Chart Type to Bar.
  4. Select any Type, i.e. Feature.
  5. Select Aggregate by to be Team / project.
  6. Save the Custom View
  7. Navigate the to Parent team that has other child teams.

The widget shows data from only one Team and not from all child's team. Please note data exists for all teams.

Environment

Rally SAAS

Cause

Browser cache and cookies

Resolution

These solutions address the issue of widget settings that are being persisted due to cache. If the issue persists after trying these steps, further investigation may be required.

  1. Clear Browser Cache and Cookies Settings in your browser : This will reset the widget configuration.
  2. Use Incognito Mode                                                                : Incognito mode does not save browser data, so it can be used to reset the widget settings.
  3. Delete and Re-add the Widget                                                : This may resolve any corrupted settings.
  4. Copy the Custom Page                                                           : Before deleting the custom view page, try copying the custom view page it might also resolve the issue.
  5. Delete the Custom View Page                                                : If the issue still persists, delete the entire custom view page and recreate the page.

Additional Information