"Hosts with connectivity issues" for witness appliance is seen when checked from any ESXi node CLI "esxcli vsan health cluster list" while vCenter Skyline Health reports cluster is healthy.
search cancel

"Hosts with connectivity issues" for witness appliance is seen when checked from any ESXi node CLI "esxcli vsan health cluster list" while vCenter Skyline Health reports cluster is healthy.

book

Article ID: 393353

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

  • When checking the vSAN cluster on vCenter Skyline Health, the checks related to "Network" and "Hosts with connectivity issues" are green. In other words, there are no errors seen on Skyline Health.
  • However, when checking on an SSH session of one of the nodes in the cluster with the command "esxcli vsan health cluster list", the status for "Network" and "Hosts with connectivity issues" are seen as "red".
  • And when checking further with the command "esxcli vsan health cluster get -t 'Hosts with connectivity issues' ", it is seen that the error is related to the vSAN witness host.

Environment

VMware vSAN 7.0.x

VMware vSAN 8.0.x

Cause

This is a known issue that happens in very rare situations when users separate witness traffic from vSAN traffic because of the different logical checks done by vCenter and ESXi levels.

 

 

Resolution

There is no fix available at the moment. Please check this document periodically for updates.

In this case, vCenter health checks take precedence and as long as Skyline checks are green, the error seen on the ESXi SSH session can be safely ignored.