vSAN host shows as network partition from the rest of the vSAN cluster
VMs are down and showing as inaccessible in vCenter
vSAN traffic using a LAG
vmkping tests to/from all hosts in the cluster are successful
Unicast agent list/table is intact/built for all hosts
Environment
VMware vSAN (All Versions)
Cause
The active vmnic within the LAG being used for vSAN traffic is not receiving traffic from the upstream switch
Resolution
Engage your networking team for further assistance
Connect to the impacted host via SSH
Run esxcli vsan network list to get the vmk in use by vSAN
Run esxtop > type n to get to networking
See which vmnic is actively being used by the vSAN vmk
Select the impacted host in vCenter > Configure > Networking > Virtual switches
Select the Virtual switch being used for vSAN traffic
Expand the Uplinks and look for the vmnic you got from step 5
Click on the 3 ellipses (...) > View Settings and look at the CDP info to see which switch and port the host is connected to Note: This info is not always populated so you may have to provide the MAC address for the vmnic to your networking team. The MAC address can be found from host > Configure > Networking > Physical adapters
Have your networking team confirm the switch & port the host is connected to from the switch side and have them check the logs for any issues
Try bouncing the vmnic from the ESXi host by running esxcli network nic down -n vmnic followed by esxcli network nic up -n vmnic