Site Recovery Manager or vSphere Replication Plugin shows not accessible in vCenter
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Site Recovery Manager or vSphere Replication Plugin shows not accessible in vCenter

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Article ID: 393317

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

1. vSphere Replication or Site Recovery Manager configure option is grayed out in vCenter 

2. Open Site Recovery option is grayed out in vCenter 

3. Reconfiguring the appliance from VAMI is successful but the plugin status does not change to OK 

Environment

VMware vSphere Replication 
VMware Site Recovery Manager 
VMware Live Site Recovery 

Cause

1. This occurs when the appliance certificate is issued to 'unknown' rather than a valid certificate. The certificate may appear as 'unknown' if it has been upgraded from version 8.2.

2. This occurs when the appliance certificate is issued to a short name instead of the fully qualified domain name (FQDN).

Resolution

Follow the steps below to fix this issue - 

1. Access the appliance via SSH and update the hostname to FQDN if it is currently a short name or does not match the DNS host record.

A. For appliance versions 8.8 and above, follow the instructions in Photon Network Manager Commands to update Hostname/IP Address/DNS in SRM & vSphere replication (312686)

B. Refer to the instructions below for appliance versions 8.7 and earlier

root@Appliance cd /opt/vmware/share/vami 

root@Appliance [ /opt/vmware/share/vami ]# ./vami_config_net
Main Menu
0)      Show Current Configuration (scroll with Shift-PgUp/PgDown)
1)      Exit this program
2)      Default Gateway
3)      Hostname
4)      DNS
5)      Proxy Server
6)      IP Address Allocation for eth0
Enter a menu number [0]: 3

Press 3 to change the hostname to FQDN

2. Change the appliance certificate and ensure its getting assigned to FQDN. This procedure is the same for VRMS and SRM. 

3. Reconfigure the appliance 

This should fix the error.