vSAN Health Service : Physical Disk Health : Component Metadata Health
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vSAN Health Service : Physical Disk Health : Component Metadata Health

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Article ID: 393310

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Updated On:

Products

VMware vSAN

Issue/Introduction

This health check verifies the integrity of the component metadata on a disk.

Environment

VMware vSAN

Cause

If this health status from this check is not green (OK), vSAN has encountered an issue with an individual component.

 

This error will not cause vSAN to decommission the disk on which the component resides. But in rare cases where bad metadata is detected, the problem might lead to additional issues with the object that contains the component. In particular, if the number of prepared I/O equals 255, or if the number of committed I/O​ is larger than 10,000, the Component metadata health check returns an error (this particular criteria was removed in vSphere 6.0 patch 03 and later releases).

Resolution

This error might be caused by faulty drives, a faulty controller, or a misbehaving device driver, but it might be intermittent and originate from the vSAN software. The best approach would be to isolate each storage component from the software and hardware layer, validating from the vendor's GUI if the information matches in the virtual layer in the Web client.

The commit I/O larger than 10,000 failure might be intermittent (this particular criteria was removed in vSphere 6.0 patch 03 and later releases). But other test failures might require VMware Support.

For more information, see Creating and managing Broadcom support cases