Sensor fails to update policy after change hint applied in Carbon Black Cloud Console
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Article ID: 393234
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Updated On:
Products
Carbon Black Cloud Endpoint StandardCarbon Black Cloud Audit and RemediationCarbon Black Cloud Audit and Remediation (formerly Cb Live Ops)Carbon Black Cloud ContainerCarbon Black Cloud Endpoint Standard (formerly Cb Defense)Carbon Black Cloud Enterprise EDRCarbon Black Cloud Enterprise EDR (formerly Cb Threathunter)Carbon Black Cloud Managed Detection (formerly Cb Threatsight)Carbon Black Cloud Managed Detection and ResponseCarbon Black Cloud Managed Threat HuntingCarbon Black Cloud PreventionCarbon Black Cloud Workload
Issue/Introduction
A sensor might show a grayed out policy name for the newly applied policy in the Carbon Black Console.
Environment
Carbon Black Cloud Console: Current Version
Carbon Black Cloud Windows Sensor: All Versions
Microsoft Windows OS: Supported Versions
Cause
The Carbon Black Cloud backend will create the hint for the policy change and show that new policy as grayed out in the console view, but the sensor never gets the hint to change policy and stays in the original policy.
Resolution
From the Carbon Black Cloud Console, select the problem endpoint from the Inventory > Endpoints page
Click "Take Action" > "Assign Policy" and apply original policy back to the endpoint (can also choose any other policy like "Standard")
Once the sensor has a successful check-in and moves into the chosen policy from Step 2, this validates the sensor is picking up policy hints successfully
Try to move the sensor into the desired policy once again and validate the sensor now moves into the correct policy on its subsequent check-in.