vSAN node storage unavailable and showing no disks
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vSAN node storage unavailable and showing no disks

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Article ID: 393221

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Updated On:

Products

VMware vSAN

Issue/Introduction

In vSAN disk management a host will show no disks or disk groups 
disk group will show disks in use as 0/0 or 0/<number> 

The disks and storage adapters are visible from hardware management and shows no errors but ESXi and vCenter are not showing them

When reviewing the disks from the host point going to host > configure > storage devices
The expected disks for vSAN are not seen

When reviewing the storage adapters by going to host > configure > storage adapters 
The expected storage adapter is not seen




Environment

vSAN (All versions) 

Cause

This is caused by the drivers not loading for the storage adapter 

Resolution

Confirm what driver the storage adapter should be running in one of the following methods

  • Review another working host with the same hardware by running the following command on the host's CLI:
  • Review the vSAN I/O Controller Compatibilty Guide to find your controller and required drivers
  • Request assistance from your hardware vendor to confirm the correct drivers

Confirm the drivers are installed using the following command on the impacted host's CLI:

esxcli software vib list

Check if the drivers are loading using the following command on the impacted host's CLI:

esxcli system module list
  • if you do not see the drivers in this list load the drivers using the command: 
    esxcli system module load --module=<driver module name> 
    

     

    You can review a working host to get the full driver module name if needed 

Once the module is loaded make sure you fully enable the module for use after reboot using command: 

esxcli system module set --enabled=true --module=<driver module name>

Finally place the host in to maintenance mode and reboot the host. 
Once rebooted confirm disks are now visible and remove host from maintenance mode

Additional Information

When host reboots due to power interruption (or any other external factors), there is a chance that returning node would not detect disk drives properly.  
When encountered, it is recommended to issue a consecutive restart via usual means (soft/cold reboot) in order for all devices to initialize properly.