VMware Cloud Director UI fails to load or shows "Unable to perform query" with an NSX-T Load Balancer
search cancel

VMware Cloud Director UI fails to load or shows "Unable to perform query" with an NSX-T Load Balancer

book

Article ID: 393152

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • You may see "Unable to perform query" after logging in to the VCD UI.
  • Browser developer tools show a 502 Gateway error on cloudapi requests.
  • Bypassing the Load Balancer by adding the IP and FQDN to your local machines host file does not work.

Environment

VMware Cloud Director
NSX-T

Cause

  • NSX-T Load Balancer profile settings are using default or insufficient values for Request/Response Header size and timeouts.
  • This prevents larger payloads from passing through the Load Balancer.

Resolution

Update the HTTP/HTTPS Load Balancer profile under: Networking > Load Balancing > Profiles > HTTP & HTTP

Use the following configuration:

  • Type: HTTPS
  • HTTP Request Header: X-Forward-For
  • Idle Timeout: 15 Seconds
  • Response Timeout: 60 Seconds
  • Request Header Size: 65535
  • Response Header Size: 50000

These details are outlined in the VMware Cloud Director Cell Load Balancing Configuration guide.

Additional Information

  • To verify, inspect the network tab in browser developer tools. Refresh the VCD page and look for a failed request to cloudapi.
  • If the load balancer is misconfigured, the request will fail with a 502 Gateway error.