554 Tenant Not Assigned. Missing X-DetectorID.
search cancel

554 Tenant Not Assigned. Missing X-DetectorID.

book

Article ID: 393118

calendar_today

Updated On:

Products

Data Loss Prevention Core Package

Issue/Introduction

After routing mail to Symantec Data Loss Prevention Cloud Service for Email for the first time mail is rejected with the following error present in the rejection email.(NDR)

Error:    550 5.0.350 Remote server returned an error -> 554 Tenant Not Assigned. Missing X-DetectorID. Please check the configuration in the latest copy of the DLP Cloud Service for Email Implementation Guide. 
Message rejected by:    mail.ds.dlp.protect.symantec.com

Cause

Incorrect header is added to the inbound mail connector within O365 

Resolution

Ensure that the X-DetectorID header is set to your detectorID while performing the steps for 'Creating a rule that routes emails from Microsoft 365 to your DLP cloud detector' process. 

This value is different then the Smarthost URL entered in the steps prior to 'Set a message header' during the 'Creating a New inbound Connector' process.