Cannot remove a Disk Group from the vSAN Cluster using vSphere UI
search cancel

Cannot remove a Disk Group from the vSAN Cluster using vSphere UI

book

Article ID: 393099

calendar_today

Updated On:

Products

VMware vSAN VMware vSAN 8.x VMware vSAN 7.x

Issue/Introduction

After physically removing a failed vSAN disk without properly removing the Disk Group first, could lead to a situation  where the vSphere UI will fail to remove the Disk Group with the error "Failed to remove Disk group (52b74af9-786c-f07b-b944-############). Check vSphere Client logs for details."

Environment

VMware vSAN 7.x
VMware vSAN 8.x

Cause

This is caused by not properly removing the Disk Group from the vSphere UI before physically removing/replacing the failed disk.

Resolution

1. Put Host into Maintenance mode from the vSphere UI.

2. Identify the failed disk/Disk Group by using following command

   #esxcli vsan storage list

The failed disk will show up as Unknown

   Device: Unknown
   Display Name: Unknown
   Is SSD: false
   VSAN UUID: 52be1a3c-2031-364c-0a52-############
   VSAN Disk Group UUID:
   VSAN Disk Group Name:
   Used by this host: false
   In CMMDS: false
   On-disk format version: -1
   Deduplication: false
   Compression: false
   Checksum:
   Checksum OK: false
   Is Capacity Tier: false
   Encryption Metadata Checksum OK: true
   Encryption: false
   DiskKeyLoaded: false
   Is Mounted: false
   Creation Time: Unknown

3.  Follow KB listed below to remove the DG

How to manually manage and configure a vSAN disk group using esxcli commands

4. Create the Disk Group by following Steps in tech Doc below:

Create a Disk Group on a vSAN Host