Appliance node not accepting new root password
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Appliance node not accepting new root password

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Article ID: 393065

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Updated On:

Products

VMware NSX

Issue/Introduction

You are following the document for resetting a password on an NSX appliance. The appliance goes through the motions, but after setting the password, you still are not able to login.

Environment

VMware NSX

VMware NSX-T Datacenter.

Cause

Due to issues in using the console, sometimes when attempting to change the password of an appliance, the session may not send the same keystrokes that you are typing, or the password you are using does not meet the minimum requirements.

Resolution

  • Retry, multiple times.
  • Make sure your password is not a dictionary word.
  • Make sure you have at least 12 characters.
  • Make sure you have at least one each of the following character classes: Upper case letters, Lower Case Letters, Numbers, Symbols (Characters above the numbers are the safest, as some symbols are not allowed.)
  • Proceed slowly. Try generating a password using a password generator. Also, try using two words with some letters replaced by numbers and or symbols. (.e.g. visiblelight becomes V1sibl3L!ght)
  • If you are not using windows, or have a different keyboard layout than the one listed in the upper right corner of the console, then you should click the "Enforce XYZ Keyboard layout" button, where XYZ it the assumed layout of your physical keyboard. (Only do this if it matches your keyboard layout, i.e. US or UK keyboard layouts)

Additional Information

Note: While it will allow you to try 3x, the 3rd time appears to be false, and never moves to the confirm password prompt. If you never receive the second password prompt when updating the password, it failed.

See "Resetting the Passwords of An Appliance" in our tech docs.