Duplicate entries in the Identy Manager task panel
search cancel

Duplicate entries in the Identy Manager task panel

book

Article ID: 39304

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

Duplicate tasks tabs are appearing in the Identity Manager console when viewing the Tasks tab panel. Each tabs have exactly the same options in them and both are fully functional.

 

 

Environment

 

 

Cause

When Category Order is set to a mismatched order number for a task, this will create a duplicate tab with equivalent tasks options. This issue is reproduced after the RoleDefinitions.xml has been imported and when a category order value of “0” or greater than “20” is selected. This occurs when one or more tasks are modified causing a mismatch. 

 

Resolution

Ensure that category order is matching all other tasks within category and that none of them are mismatched. This can be done from the Roles and Task XML or through the Identity Manager GUI. Once this is fixed, restart the environment for changes to take place.

 

Detailed Resolution Steps:

  1. Click on the Duplicate Tab.

  2. Note the Tasks that are listed under the Duplicate Tab.

  3. Modify each Task: Roles and Tasks>Admin Tasks>Modify Admin Task>Search for and select one of the tasks listed on the Duplicate Tab(s).

  4. On the Profile Tab of the Task set the 'Task Order' drop down menu to '0'.

    Note: Ensure the "Category order" is the same for all tasks"

  5. Submit the Task.

  6. Repeat steps 3/4/5 for each of the Tasks listed on the Duplicate Tab.

  7. After all the Tasks under the Duplicate Tab have been modified, log out of the IM User Console.

  8. Log in to the IM User Console and verify that the specific Duplicate Tab (whose Tasks were modified) is gone.

  9. If the Duplicate Tabs are still there after modifying ALL of the Tasks' 'Task Order' to '0', re-start the IM application server and log back into the IM User Console to check again.