NSX Application Platform (NAPP) UI not loading with error message: "Something went wrong".
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NSX Application Platform (NAPP) UI not loading with error message: "Something went wrong".

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Article ID: 392991

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Updated On:

Products

VMware NSX VMware vDefend Firewall with Advanced Threat Prevention VMware vDefend Firewall

Issue/Introduction

Symptoms:

1. If there is a change related to a datastore in your environment, the pods related to any specific worker nodes might be down.

    Login to NSX manager CLI:

    Run the commands:

  • napp-k get nodes -owide

    Identify any node in NotReady, Unknown, or Error states.

  • napp-k get pods -owide | grep -vi running | grep -vi completed

    From the above output, check if the pods that are not in a running state belong to a specific worker node. If so, copy the problematic node name.

2. On the NSX Application platform UI, you will see the message stating "Something went wrong"

 

If any one of the above symptoms do not match, this KB is not a relevant match for your problem statement.

Environment

VMware NSX

NAPP 4.2.0.1

Cause

The issue may occur if a node is not mapped to the correct datastore or if there is a network issue between the node and the datastore.

Resolution

1. Delete and Recreate the Problematic Node

From the NSX Manager CLI logged in with root, execute the below. 

Copy the problematic node that you have identified in symptom and execute the below command:

napp-k delete node <nodename>

Monitor the cluster to confirm the node is recreated using the below command:

napp-k get nodes -owide

 

2. Monitor Pod Recovery

After the node is recreated, check pod recovery using:

napp-k get pods -owide | grep -v running | grep -v completed

 

3. Validate Platform Stability

Once all pods are running, verify NAPP functionality via the UI:

  • Log in to NSX Manager UI.
  • Navigate to System > NSX Application Platform.
  • Confirm that the platform status is Stable.

 

Additional Information

If the issue persists, please contact VMware support.