SNMPv3 on NSX Manager node is not working
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SNMPv3 on NSX Manager node is not working

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Article ID: 392941

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Updated On:

Products

VMware NSX VMware NSX-T Data Center

Issue/Introduction

  • SNMPv3 on NSX Manager node is not working
  • You have configured SNMPv3 on the NSX manager node following the official document
  • You do not see any errors on the NSX manager logs

  • When you check the status of the service, it is stopped
    NSX-Mgr-01> get service snmp
    Tue Apr 01 2025 UTC 07:41:45.386
    Service name:      snmp
    Service state:     stopped
    Start on boot:     True


  • /etc/init.d/vmware-snmpd start command completes without error, however the service does not come up

    root@NSX-Mgr-01:/var/log# /etc/init.d/vmware-snmpd start
    [ ok ] Starting vmware-snmpd (via systemctl): vmware-snmpd.service.

    root@NSX-Mgr-01:/var/log# /etc/init.d/vmware-snmpd status
    * vmware-snmpd.service - LSB: VMware SNMP agent
       Loaded: loaded (/etc/init.d/vmware-snmpd; generated)
       Active: active (exited) since Mon 2021-02-15 18:53:53 UTC; 4 years 1 months ago

  • The uptime on the NSX manager nodes is more than 1500 days

Environment

VMware NSX-T Data Center 

Cause

This issue can occur if there are no regular maintenance of NSX-T nodes. 

Resolution

To resolve the issue, reboot the NSX manager node. 

Once the reboot is completed, check the status of the SNMP service by running the command get service snmp as admin user or /etc/init.d/vmware-snmpd status as root user.


Note: If the issue persists after the reboot, collect the NSX manager node support bundles and open a support request with Broadcom by following Creating and managing Broadcom support cases.

Additional Information

It is recommended to regularly upgrade the NSX to the latest version to benefit from new features, security patches, and improved stability, as VMware regularly releases updates.