Unable to configure NSX on nodes which were rebuilt in the cluster : Error Code 100
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Unable to configure NSX on nodes which were rebuilt in the cluster : Error Code 100

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Article ID: 392879

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Updated On:

Products

VMware NSX

Issue/Introduction

Install Failure : while preparing an ESXi host as a Transport Node, the following error is seen.

Error: General error has occurred. (Error code:100)

Environment

VMware NSX

Cause

When an ESXi host is removed directly from vCenter without first removing NSX, it can result in entries for that host remaining in the NSX database.

The correct procedure to remove NSX from a single host:  Uninstall NSX Data Center from a Managed Host in a vSphere Cluster

Resolution

Install Failure Prerequisite

Before proceeding with the following options, move the host that has failed to install/upgrade out of the vSphere cluster and make it a standalone host in vSphere.

If the host does not appear in the NSX UI, below steps can be used to remove the transport node by using an API call :

  1. Run the following API call:
    "GET https://<NSX Mgr IP>/api/v1/transport-nodes/state" 

  2. Make a note of the UUID which has the state value :"Failed"

  3. Run another API call with the UUID found from step 2 :
    "GET https://<NSX Mgr IP>/api/v1/transport-nodes/UUID/state" 

  4. If the state value in the API response is not "Object Not found" then proceed to step 5.
    Note: The state value should be "Object Not Found" when the host is successfully removed.

  5. For NSX-T 3.2.x and 4.x, run the following API call:
    "DELETE https://<NSX Mgr IP>/api/v1/transport-nodes/<UUID>?force=true&unprepare_host=false".

    OR

    CURL option: 
    curl -k -H "Content-Type:application/json" -u admin -X DELETE https://<NSX Mgr IP>/api/v1/transport-nodes/<UUID>?force=true&unprepare_host=false

  6. Wait five minutes, then run the GET transport node state command again, as seen in Step 3 periodically until "Object Not found" is returned.

  7. Once GET API returns "Object Not found", move the host back into the original cluster to prepare it for NSX, If a Transport Node Profile is applied, host preparation should start automatically. Otherwise, proceed and prepare the transport node as before.

Additional Information

If you are contacting Broadcom support about this issue, in order to aid a timely response and resolution, please provide the following:

  1. NSX version.
  2. Was the issue encountered during an upgrade or install.
  3. Where all workaround options completed and if not, which options were not completed and reason why they were not completed or what issue prevented completion of them.
  4. NSX Manager log bundles.
  5. ESXi host log bundles for hosts that are failing to configure as transport nodes.
  6. Text of any error messages seen in NSX GUI or command lines pertinent to the investigation and screenshot.

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