Information to provide Broadcom for DX UIM uninstallation verification
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Information to provide Broadcom for DX UIM uninstallation verification

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Article ID: 392866

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

  • This document outlines the information that can be used to verify DX UIM has been uninstalled in your environment.

  • Some of this information must be gathered prior to uninstalling the product, so please follow the steps carefully.

Environment

  • DX UIM 20.x or higher

Cause

  • Uninstallation guidance

Resolution

  1. Prior to uninstalling DX UIM, gather a Usage Metering Report as described in the following KB:  (Manually Gather a Usage Metering Report)

  2. Uninstall UIM components in the following order:

    a. Uninstall/Decomission any Remote Hubs/Robots
    b. Uninstall CABI (as this is an optional component it may not be installed - if not, proceed with the remaining steps)
    c. Uninstall Operator Console
    d. Uninstall DX UIM from the Primary Hub
    e. Purge/Archive DX UIM Database
    f.  Uninstall Infrastructure Manager client

    More information on each of these steps is available under "Additional Information" below.

  3. For each of the UIM Core component servers (CABI, Primary Hub, and Operator Console Nodes) follow the steps given to verify the removal:

    Windows:

    After uninstalling, navigate to the installation folder where DX UIM was installed (usually C:\Program Files (x86)\) and delete the leftover "Nimsoft" folder.

    Check to make sure there are no other "Nimsoft" installation directories on other drives.

    Now open a command prompt, and navigate to the same location (e.g., C:\Program Files (x86)\) and run the following command:

       dir /s /a > (filename).txt

    Where (filename) is a unique filename that should include the name of the DX UIM component which was uninstalled.

    This will create a file that lists all the folders and subfolders in order to verify the product is no longer present.

    For example, on the Primary Hub, run  "dir /s /a > primaryhub_dir.txt"  and on the Operator Console run "dir /s /a > operatorconsole_dir.txt" and on CABI run "dir /s /a > cabi_dir.txt"


    Linux:

    After uninstalling, navigate to the installation folder where DX UIM was installed (usually /opt/) and delete the leftover "nimsoft" folder.

    Now run the following command to generate the directory listings as described above:

    ls -laR > (filename.txt)

    Where (filename) is a unique filename that should include the name of the DX UIM component which was uninstalled.

    This will create a file that lists all the folders and subfolders in order to verify the product is no longer present.

    For example, on the Primary Hub, run  "ls -laR > primaryhub_dir.txt"  and on the Operator Console run "ls -laR > operatorconsole_dir.txt" and on CABI run "ls -laR > cabi_dir.txt"

  4. Gather all three .txt files containing the directory listings and submit them to Broadcom along with the usage metering report.

Additional Information

Uninstall/Decomission UIM Hubs/Robots


Uninstall CABI


Uninstall Operator Console


Uninstall DX UIM from Primary Hub

Regarding the UIM Database: The data collected by DX UIM will be stored in the backend database (MySQL, Oracle, MSSQL).   This data may need to be handled as per your organization's policies for data retention.  Consult with your DBA for the best practice regarding the storage, archival, or deletion of the database.

Infrastructure Manager can be removed from workstations via the Add/Remove Programs functionality under Windows Control Panel.


Note: 

In case that your licenses are subscription-based, you must remove all installation media files beyond any perpetual entitlements that you may have.

Example:

  • Up to perpetual license version 20.1, any installation media beyond this version must be deleted.

  • If you have installation media for 20.4 and above you MUST delete it from all systems.