Loss of Azure Tags in Cloud Zones at the Availability Zone Level
search cancel

Loss of Azure Tags in Cloud Zones at the Availability Zone Level

book

Article ID: 392841

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Loss of tags under Azure for Availability Zone objects at the Cloud Zone level.

  1. It seems to happen randomly at any time.
  2. The loss of tags is limited to the Azure account.
  3. It is not always the same Cloud Zone that has the problem.

The adapter host service /services-logs/prelude/adapter-host-service-app/file-logs/adapter-host-service-app.log logs shows the enumeration of cloud zones fails:

  • 2025-03-04T19:06:55.709Z WARN public-adapters [host='adapter-host-service-app-#########-#####' thread='azure-executors-##' user='' org='' trace='' parent='' span=''] c.v.p.c.m.a.a.e.AzureComputeEnumerationAdapterService.lambda$collectAvailabilityZones$6:738 - [/resources/endpoints/#####-####-####-####-########### / [canadacentral]] Error occurred while collecting availability zones from cloud.

  • 2026-04-02T13:06:31.906Z ERROR public-adapters [host='adapter-host-service-app-##########-#####' thread='azure-executors-##' user='' org='' trace='' parent='' span=''] c.v.p.c.m.a.a.e.AzureComputeEnumerationAdapterService.lambda$getRegionAvailabilityZonesFromCloud$15:858 - Fail to get availability zones for region southeastasia.
            okhttp3.internal.http2.StreamResetException: stream was reset: CANCEL

Environment

Aria Automation 8.16.2 - 8.18.1

Cause

  • Azure has some regions where they support different counts of zones, and some regions where no zones are supported at all. So, we are enumerating the zones from the cloud. If the enumeration fails, there is a scheduled mechanism that cleans resources that are older than 1-2 enumeration cycles. Basically, they get removed as we keep Aria Automation data in sync with the cloud. And if the cloud doesn't return a zone, it may be not supported anymore, therefore removing it.

  • Due to the failed enumeration of the cloud zone, the previous cloud zone data is removed and recreated on the next enumeration cycle, therefore the "missing" tags.

Resolution

A fix for this issue is pending release Aria Automation 8.18.1 Patch 5

 

Workaround:

Add deployment properties to adjust the image enumeration for Azure:

Steps to add configuration to the provisioning-service-app deployment:

  1. Before proceeding with the change ensure a valid Backup / Snapshot has been taken
  2. Connect to one of the Aria Automation shell session
  3. Command to edit provisioning-service-app deployment:
    kubectl -n prelude edit deployment provisioning-service-app

    Note: The change is only to be applied once also in a clustered environment

  4. Add following line under "JAVA_OPTS" section
    -Dphoton-model.image.enumeration.azure.filter=nopub:nooffer:nosku:
    -Dphoton-model.EvictionRestClientCache.expireAfterSeconds=3600
  5. Restart the provisioning pods to apply the changes
    kubectl -n prelude rollout restart deployment provisioning-service-app

    Note: This will require a brief downtime as it will interrupt any activities currently running in the provisioning service.

  6. Validate the properties are applied
    kubectl -n prelude describe deployment provisioning-service-app | grep Dphoton
  7. Monitor the tags presence on affected computes.