Error: The connection to the Symantec Endpoint Database failed
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Error: The connection to the Symantec Endpoint Database failed

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Article ID: 392828

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Updated On:

Products

Information Centric Analytics

Issue/Introduction

The following error message is displayed on the Progress and Finish page of the New Connection Wizard when attempting to integrate a Symantec Endpoint Protection (SEP) data source in Information Centric Analytics (ICA):

The connection to the Symantec Endpoint Database failed

The connection to <hostname> is not functional. Please return to the previous screens and verify the server, port and database parameters.

Exception: TCP Provider: The wait operation timed out. OLE DB provider "MSOLEDBSQL" for linked server "RISKFARIC_SEP_RISKFABRIC_<hostname>_<database_name>" returned message "A network related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remove connections. For more information see SQL Server Books Online."

You have confirmed the server name or IP address, port number, and database name are correct, including the database credentials. You have also configured the firewall on the SEP database server to allow communications on the correct port.

Environment

Version : 6.x

Component : SEP Integration Pack

Cause

The connection failure is likely caused by the timeout configuration on either the SQL Server instance hosting the RiskFabric relational database or the SQL Server instance hosting the SEPM relational database.

Resolution

Ensure the setting Remote Connection Timeout in the SQL Server instance hosting the RiskFabric database is set to 0.

Ensure the setting Allow remote connections to this server in the SQL Server instance hosting the SEPM database is checked.

Both settings are accessed using SQL Server Management Studio (SSMS). Connect to each server and, in Object Explorer, right-click the server name and select Properties, then select the Connections page.

After making changes, restart the SQL Server service by opening a command prompt as an administrator and executing the following commands:

net stop MSSQLSERVER

net start MSSQLSERVER

If the RiskFabric or SEPM database is installed in a named instance of SQL Server, execute the following commands to restart the instance:

net stop MSSQL$<instance_name>

net start MSSQL$<instance_name>

If the remote connection settings on both servers were configured correctly and required no changes, you will need to troubleshoot connectivity between the servers. The following information may be useful:

  • Temporarily disable the firewall on the SEP database server
  • The default instance of SQL Server listens on port 1433 and named instances use dynamic ports. For more information, refer to Microsoft document Configure the Windows Firewall to allow SQL Server access
  • Check error logging, per Microsoft document Monitoring the Error Logs
  • SQL Server Profiler, Wireshark, the PowerShell command Test-NetConnection, and telnet can be used for tracing and diagnosing connectivity issues