vSAN Disk group unhealthy unable to remove/re-create/unmount
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vSAN Disk group unhealthy unable to remove/re-create/unmount

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Article ID: 392803

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms

The disk group cannot be removed/recreated/unmounted. Resource check failed - Internal failure happened during the resource check. Please check clomd.log on host ESXi.XXX.XXX for more details. 

Verification Steps: 

  • The vCenter vSphere UI, vCenter > Host and Cluster View > vSAN ClusterMonitor > Data Migration Pre-check shows error 

The disk group cannot be removed/recreated/unmounted.Resource check failed - Internal failure happened during the resource check. Please check clomd.log on host ESXi.XXX.XXX for more details.



  • The vSAN disk group is shown as unhealthy  In vCenter vSphere UI, vCenter > Host and Cluster View > vSAN cluster > Configure > vSAN > Disk Management, you see a Disk group with a red exclamation and Health tab showing "Permanent disk loss"

Environment

VMware vSAN (All Versions)

 

Cause

This issue occurs due to one or all of these reasons:

  • A physical Disk(s) has failed 
  • The physical disk has been removed from server, prior to removing the disk from vSAN disk group first 

Resolution

This issue can be fixed by replacing the disk and recreating the disk group mentioned in The vSAN disk appears as Absent in vSAN Disk Management