Unable to see the mainframe APM transaction traces, ERROR : Token is not set
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Unable to see the mainframe APM transaction traces, ERROR : Token is not set

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Article ID: 392783

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Updated On:

Products

DX APM SaaS DX Application Performance Management DX Operational Observability

Issue/Introduction

We have implemented the APM IA and ZAB but we are unable to see the mainframe transaction trace.

From the InfrastructureAgent mainframe log we can see the ERROR : Token is not set

Environment

  • DX O2 SaaS
  • DX O2 OnPremise 23*,24*
  • APM CloudProxy

Cause

The problem is related to defect  DE630493 to be fixed in a future release. For an update contact Broadcom Support

Resolution

As the issue requires a fix in the APM CloudProxy component, we recommend using the following 2 workarounds:

Workaround-1:

Update the "agentManager.credential" wrapper entry in the wrapper.conf file with CloudProxy Token

  • wrapper.java.additional.7=-DagentManager.credentail=<<CLOUD_PROXY_TOKEN>>

 

Workaround-2:

  • Remove the wrapper entry for agentManager.credential from the wrapper.conf file
  • Update the "agentManager.credential" property in IntroscopeAgent.profile with the CloudProxy Token.

Additional Information