Unable to see RDM devices after reboot/upgrade esxi host
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Unable to see RDM devices after reboot/upgrade esxi host

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Article ID: 392724

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

 Issue noticed with Dell Recover Point  with  RDM  devices, Under the Storage Adapters information the device's number is incorrect,  Some hosts can see all  devices but when looking at the devices list the devices show up as "Dead or Error" in  device path.

Environment

ESXi 8.X

Cause

 

Issue noticed with Dell Recover Point disconnecting the RDMs when no backup process is running.

 esxcli storage core device list -d naa.##############  command output shows device status dead.

Display Name: EMC Fibre Channel Disk (naa.##############################)

   Has Settable Display Name: true

   Size: 1484800

   Device Type: Direct-Access

   Multipath Plugin: NMP

   Devfs Path: /vmfs/devices/disks/naa.##############################

   Vendor: EMC

   Model: Invista

   Revision: 6200

   SCSI Level: 4

   Is Pseudo: false

   Status: dead  <==============no connection

 

vmkernel.log:

vmkernel.log having device scsi code "H:0x0 D:0x2 P:0x0 Valid sense data: 0x2 0x4 0x3."  means device "not ready"

025-03-13T17:46:22.052Z In(182) vmkernel: cpu56:2098191)NMP: nmp_ThrottleLogForDevice:3863: Cmd 0x8 (0x#########, 0) to dev "naa.##############################" on path "vmhba1:C0:T4:L25" Failed:

2025-03-13T17:46:22.052Z In(182) vmkernel: cpu56:2098191)NMP: nmp_ThrottleLogForDevice:3868: H:0x0 D:0x2 P:0x0 Valid sense data: 0x2 0x4 0x3. Act:NONE. cmdId.initiator=0x######### CmdSN 0x0

2025-03-13T17:46:22.052Z In(182) vmkernel: cpu56:2098191)NMP: nmp_ThrottleLogForDevice:3812: last error status from device ############################## repeated 3 times

2025-03-13T17:46:23.027Z In(182) vmkernel: cpu57:2097852)ScsiDeviceIO: 4617: Cmd(0x45dad76db100) 0x12, cmdId.initiator=0x430b9efd0120 CmdSN 0x42f06d from world 0 to dev "##############################" failed H:0x5 D:0x0 P:0x0 Cancelled from NMP layer. Cmd

2025-03-13T17:46:23.027Z In(182) vmkernel: cpu57:2097852)count Active:1 Queued:0

 

 

 

 

 

Resolution

Suggested to contact Dell Recover Point and storage support for further troubleshooting

Additional Information