UMA auto attach not working for application monitoring
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UMA auto attach not working for application monitoring

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Article ID: 392723

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

UMA autoattach does not work for .NET Applications.

Cause

Review of the logs from UMA agent seems to indicate that port 7777 is being used by another application.

Resolution

There is dxuim namespace. In that dxuim namespace there are clusterinfo and containerinfo pods running. 

exec to both pods and do env: note that containerinfo pod is using port 7777.

CAAPM_CONTAINERINFO_PORT=7777

deleted dxuim namespace as infrastructure monitoring is not being used actively and Application monitoring is more important.

redeploy the UMA agent using the original file with port 7777. This time .NET Agent is are reporting data for .NET Applications.

Additional Information

Can collect the output of netstat command and see which application is using port 7777. Modify the other application to use another port.