"Manifest Verification Failed" Error when attempting to update VCSA via ISO image through the VAMI
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"Manifest Verification Failed" Error when attempting to update VCSA via ISO image through the VAMI

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Article ID: 392548

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Updated On: 04-02-2025

Products

VMware vCenter Server

Issue/Introduction

When attempting to stage an update for the vCenter via the VAMI console, Checking for Updates via the attached ISO fails with the error message "Manifest Verification Failed"

/var/log/vmware/applmgmt/software-packages.log may contain the following:

2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_functions:Completed mounting ISO
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_b2b:Function _discoverUpdateAt called
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_b2b:discoverUpdateAt: manifest:/mnt/iso-contents packages
:/mnt/iso-contents copyfunc:<function copy at 0x7f9e3ca9d5a0>
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_functions:Can't remove directory /storage/core/software-u
pdate/tmp: [Errno 2] No such file or directory: '/storage/core/software-update/tmp'
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_functions:/storage/core/software-update/tmp directory cre
ated successfully
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_functions:Can't remove directory /storage/core/software-u
pdate/tmp/iso: [Errno 2] No such file or directory: '/storage/core/software-update/tmp/iso'
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_functions:/storage/core/software-update/tmp/iso directory
 created successfully
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_b2b:ISO discovery failed: LocalizableException({'id': 'co
m.vmware.appliance.update.manifest_verification_failed', 'default_message': 'Manifest verification failed', 'args': []}) 'Trac
eback (most recent call last):\n  File "/usr/lib/applmgmt/update/py/vmware/appliance/update/update_b2b.py", line 1902, in _dis
coverUpdateAtIso\n    _discoverUpdateAt(manifestDir, packagesDir, copyFileFunc, \'iso\')\n  File "/usr/lib/applmgmt/update/py/
vmware/appliance/update/update_b2b.py", line 1732, in _discoverUpdateAt\n    xmlManifest = verifyManifest(tempFolder)\n  File
"/usr/lib/applmgmt/update/py/vmware/appliance/update/update_b2b.py", line 299, in verifyManifest\n    raise LocalizableExcepti
on(\nvmware.appliance.update.update_functions.LocalizableException: {\'id\': \'com.vmware.appliance.update.manifest_verificati
on_failed\', \'default_message\': \'Manifest verification failed\', \'args\': []}\n'
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_functions:Unmounting ISO
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_functions:/var/run/vmware/applmgmt directory created successfully
2025-03-26T20:27:01.085 [263640]DEBUG:vmware.appliance.update.update_functions:Unmounting device

In the Update Manager tab of vCenter, the following may also be shown when attempting to read the ISO:

Environment

VMware vCenter 7.0.x

VMware vCenter 8.0.x

 

Cause

This issue occurs when the vCenter Upgrade ISO image is corrupt. 

 

Resolution

To compare these values the following commands may be used per Guest OS:

Windows

  1. Open the Windows command line.
  2. Navigate to the folder that contains the ISO whose MD5 checksum you want to check and verify. 
  3. Type the command below: 
certutil -hashfile <filename> MD5

Compare the MD5 of the existing ISO in your environment to the available MD5 and SHA2 sums available on the Broadcom Download Portal. 

Mac

  1. Open Terminal
  2. Navigate to the folder containing the ISO whose MD5 checksum you want to verify.
  3. Type the command below followed by the filename:
md5 <filename>

Linux

  1. Open Terminal
  2. Navigate to the folder that contains the ISO whose MD5 checksum you want to check and verify. 
  3. Type the command below:
 md5sum <filename>

If the MD5 does not match, please download a new copy of the ISO file from the Broadcom Customer Support portal and upload the new valid ISO to a datastore for the vCenter to use. If the values do match, please attempt to upload the ISO to the datastore for the vCenter again and attempt upgrade again.