BackupRepository status is logging error messages but the phase is Ready
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BackupRepository status is logging error messages but the phase is Ready

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Article ID: 392506

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Updated On:

Products

Tanzu Kubernetes Runtime

Issue/Introduction

The backupRepository CR is Ready and backupRepository maintenance tasks are completing successfully, however the status is showing error messages.

kubectl get backupRespoitory <backup Repository name> -n velero
:
status:
  lastMaintenanceTime: "2025-03-30T11:30:59Z"
  message: 'error to get repo options: error to get repo credentials: error get s3
    credentials: failed to refresh cached credentials, no EC2 IMDS role found, operation
    error ec2imds: GetMetadata, exceeded maximum number of attempts, 3, request send
    failed, Get "http://169.254.169.254/latest/meta-data/iam/security-credentials/":
    dial tcp 169.254.169.254:80: connect: connection refused'
  phase: Ready

In this particular scenario, the error message is related to s3 credentials but this issue is not confined to any particular error message.

Cause

There is a known issue where such error messages are observed during repository maintenance activities but are not cleared once the issue is resolved.

Resolution

Update the backupRepository CR and delete "status.message".

kubectl edit backupRespoitory <backup Repository name> -n velero

Confirm the message no longer appears after further backupRepository maintenance activities. Check .status.lastMaintenanceTime for time of most recent maintenance activity.

Additional Information

https://github.com/vmware-tanzu/velero/issues/7810