Unable to retrieve vSAN Disk Management information via vSphere client.
search cancel

Unable to retrieve vSAN Disk Management information via vSphere client.

book

Article ID: 392486

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

vSAN Disk Management fails to load in the HTML5 vSphere client, with the below error:

"Unable to extract requested data. Check vSphere Client logs for details."

Environment

VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x

Cause

One of the nodes in the cluster may have encountered a hardware issue, and has now entered a "not responding" state.
The host in this state can cause issues for the retrieval of data from all the nodes participating in the cluster.

 

Resolution

Remove host "not responding" host from the cluster, Then once the underlying issue with the node has been resolved it can be added back into the cluster. 

Additional Information