Data collection for vSphere cloud accounts is failing in Aria Automation. Communication to the accounts and password is working as image synchronization and provisioning status is still completing successfully.
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Data collection for vSphere cloud accounts is failing in Aria Automation. Communication to the accounts and password is working as image synchronization and provisioning status is still completing successfully.

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Article ID: 392392

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • The data collection can run for a long time and eventually fails.
  • Provisioning service logs located under /services-logs/prelude/provisioning-service-app/file-logs/provisioning-service-app.log contains the following error messages.
    • java.util.concurrent.CompletionException: java.lang.IllegalStateException: Failed to retrieve properties.
    • Fault received from vCenter  [...]   The session is not authenticated.
    • Existing connection has been closed or is invalid. Removing it from pool.

Environment

  • VMware Aria Automation 8.x

Cause

Transient communication issues between Aria Automation and vCenter an cause data collection to become stuck requiring a restart to resolve

Resolution

Where the data collection job is getting stuck due to issues on the service pods, we can resolve it in two ways:

  •  You can mark the data collection for a cloud account as Failed using this API call. It will restart automatically within 10 minutes.
    • curl -kv --location --request PATCH 'https://<FQDN>/iaas/api/cloud-accounts/<cloud_account_id>?apiVersion=2021-07-15' \
      --header 'Authorization: Bearer <access_token>' \
      --header 'Content-Type: application/json' \
      --data-raw '{
        "customProperties": {
          "enumerationTaskState": "FAILED"
        },
        "privateKey":"<vSphere_password>",
        "privateKeyId":"<vSphere_username>"
      }'
        
  • Alternatively, delete the 3 provisioning-service-app pods to restart this service which is responsible for data collection (among other things)
    Note that VM provisioning and other functions will be unavailable for a few minutes while the pods restart.
    1. Get pod names:  
      • kubectl -n prelude get pods | grep provisioning-service-app
    2. Restart pods:  
      • kubectl -n prelude delete pods <POD1> <POD2> <POD3> 

 

For the same issue regarding image synchronization, see KB 326017: Restarting stuck image synchronization in VMware Aria Automation

Additional Information