IMPS failed to start after upgrade from 14.4 to 14.5
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IMPS failed to start after upgrade from 14.4 to 14.5

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Article ID: 392373

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Seeing the following error after IMPS upgrade from 14.4 to 14.5.  provision server fail to start 

Error importing LDIF file 'D:\Program Files (x86)\CA\Identity Manager\Provisioning Server\data\eta_local_reg.ldif'. Reason: javax.naming.NamingException: javax.naming.NamingException: javax.naming.ServiceUnavailableException: [LDAP: error code 52 - Unavailable]
Install, com.ca.etrust.install.admin.ConfigureAdminServer, err, An error occurred and product update failed.  Look at the log file C:\Users\xxxx\AppData\Local\Temp\2/imps_server_install.log for details.
Install, com.ca.etrust.install.admin.ConfigureAdminServer, err, ProductException: (error code = 200; message="Java error"; exception = [javax.naming.NamingException: javax.naming.NamingException: javax.naming.ServiceUnavailableException: [LDAP: error code 52 - Unavailable]])

STACK_TRACE: 16

ERROR: Invalid Server credentials. ldap://hostnamexxx:20390/ with credentials cn=etaxxx,dc=eta

Environment

Identity Manager 14.5 Standalone

Cause

This is due to CA directory problem.   impd-main failed to start.   impd-trusted.pem in ssld has changed to a newer version after the upgrade, and the dxmanaged service was expecting old certs.

Resolution

Replace new cert with old cert and restart DXserver.