Resolving SMTP Relay Configuration Issue with Special Character Ampersand (&) in Password of SMTP Relay Account
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Resolving SMTP Relay Configuration Issue with Special Character Ampersand (&) in Password of SMTP Relay Account

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Article ID: 392096

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

Overview

This article offers a solution for resolving SMTP relay configuration issues in Identity Manager, particularly when the special character ampersand (&) is present in the SMTP_PASSWORD parameter. This setup complication arises when the SMTP relay at public relay smtp.mailgun.org that requires AUTH LOGIN authentication from SMTP clients.

Problem Description

When setting up an SMTP relay with smtp.mailgun.org, which requires AUTH LOGIN authentication, users may face Identity Manager startup issues if the SMTP_PASSWORD contains special character, such as the ampersand (&). This problem is found in environments where the SMTP_USER and SMTP_PASSWORD must be provided in the email.properties file located at /opt/CA/VirtualAppliance/custom/IdentityManager for Virtual Appliance deployment type only.

Environment

Vaap 14.5.1 CHF01
SMTP Relay Server: smtp.mailgun.org or any SMTP server requiring authentication

Cause

On-Screen Error: The execution of start_im or restart_im results in:

Job for wildfly-idm.service failed because the control process exited with error code.
See "systemctl status wildfly-idm.service" and "journalctl -xeu wildfly-idm.services" for details.

Server Log Error: Errors reported in server.log include when using [email protected] and SMTP_PASSWORD=Password&1 for example:


OPVDX001: Validation error in ca-standalone-full-ha.xml
...
Unexpected character '<' (code 60) in attribute value

Resolution

  1. Configure a New SMTP Password:
  •     Set Up the SMTP Server: Access the SMTP server settings to create a new password that excludes the ampersand (&) or other problematic special characters.

     2. Update the Configuration File:

  •     File Location: Navigate to /opt/CA/VirtualAppliance/custom/IdentityManager/email.properties
  •     Edit and Update: Open the file with sufficient permissions.
  •     Modify SMTP_PASSWORD Entry:

    SMTP_PASSWORD=NewPasswordWithoutSpecialChar

    3. Restart Identity Manager Service:

  • Apply Changes: Restart the Identity Manager service to apply configuration updates: 

    restart_im

    or,

    stop_im follwed by start_im

      4. Service Status Check: Ensure the service is running smoothly: 

  • issue the command "s" to see if im started sucessfully

     5. Log Monitoring: Check server.log, test with a PX for example to send e-mails to confirm emails are arriving via SMTP relay just configured.