Virtual Machines Lose Network Connectivity After NSX Manager Is Restored from Backup.
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Virtual Machines Lose Network Connectivity After NSX Manager Is Restored from Backup.

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Article ID: 392019

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Updated On:

Products

VMware vCenter Server VMware NSX

Issue/Introduction

  • Virtual machines report network connectivity loss after the NSX manager restored from the backup.
  • Virtual machine ports attached the distributed switch report port status as blocked.
  • Port status as per net-dvs -l for the virtual machine

    com.vmware.common.port.volatile.status = inUse linkUp blocked portID=####### Port blocked by admin propType = RUNTIME
  • On the ESXi host /var/log/nsx-syslog.log shows the following entry

    cfgAgent[185909808]: NSX 185909808 - [nsx@6876 comp="nsx-controller" subcomp="cfgAgent" tid="FD7A4700" level="error"] The VIF info ####-####-####-#### doesn't match. (DVPort ####-####-####-####) and (LSP ####-####-####-####)

Environment

VMware NSX
VMware vCenter Server

Cause

If there are network configuration changes that happened after the backup was taken, these changes will not be recorded and will not be automatically updated after the restore.
NSX manager detects a conflict in the information available and the information received from the ESXi host and blocks the port.
vCenter should be considered the source of truth for the VM’s location and network, even after the NSX restore. Therefore, syncing the restored NSX Logical Port from backup will be incorrect, and user intervention will be required to properly reconnect the VM.

Resolution

  • Following workarounds can help to unblock the virtual machine port:

    • vMotion of affected virtual machines to a different ESXi host
    • Changing to a new portgroup and moving it back to the original one.
    •  Using port unblock command :

      net-dvs -s com.vmware.common.port.block=false <N-VDS-Name> -p <LogicalSwitchPortUUID>

Additional Information

If the provided resolution does not resolve the issue, please submit a support request.
Reference Knowledge Base article: Creating and managing Broadcom support cases