The capacity of the vSAN datastore is displayed as 0 bytes. The vSAN cluster is intact.
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Article ID: 392018
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Updated On:
Products
VMware vSAN
Issue/Introduction
Symptoms:
The capacity of the vSAN datastore appears as 0 bytes when the user tries to check it. All the ESXi hosts are part of the vSAN cluster with no host in maintenance mode.
When the user checks the diskgroup status, all the disk groups in the vSAN cluster are in a locked state. vSAN encryption is enabled.
Environment
VMware vSAN 7.0.x
VMware vSAN 8.0.x
Cause
This issue happens because all the diskgroups in the cluster are in an unmounted state, and when we check the state of the disk group from vSAN cluster->configure->disk management, we see the health status of the disk group as locked.
Since all the disk groups are locked and unmounted, the capacity of the vSAN datastore is shown as zero.
Resolution
In an encrypted vSAN cluster, when communication between a host and the KMS is lost, the disk group can become locked if the host reboots. When a host reboots and is unable to retrieve the KEK from the KMS, the vSAN locks the host's disk groups. The disks behave as if they are unmounted. Objects on the disks become inaccessible.
The user can view a disk group's health status on the Disk Management page in the vSphere Client. An encryption health finding warning notifies you that a disk is locked.
Hosts in an encrypted vSAN cluster do not store the KEK on disk. If a host reboots and cannot get the KEK from the KMS, vSAN locks the host's disk groups. To exit the locked state, you must restore communication with the KMS and reestablish the trust relationship.