Clarity multicast not working after migrating to new RHEL 9 server
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Clarity multicast not working after migrating to new RHEL 9 server

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Article ID: 391923

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

We are facing multicast address issues on the clarity Production server and have added Multicast Address beacon ports configured in the firewall rule. 

The admin tower test command from the clarity servers has the following errors (The same messenger failed messages found in Beacon system logs:

[main] ppm.messaging Unable to create channel: Messenger init failed...
com.niku.union.config.ConfigurationException: Messenger init failed...
Caused by: com.niku.union.config.ConfigurationException: Messenger failed to open channel...
Caused by: java.net.BindException: [TCP] /IP ##.##.#.# is not a valid address on any local network interface

Cause

Bindaddress was configured with the incorrect IP addresses

Resolution

Validate the BindAddress values (IP address or hostnames) used in CSA /Properties.xml file for all the affected Clarity Servers.