Open Source Telagraf Agent is not picking up metrics
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Open Source Telagraf Agent is not picking up metrics

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Article ID: 391756

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

An open source telegraf agent configured with a Cloud Proxy in Aria Operations is no longer pushing metrics to Aria Operations

Environment

Aria Operations 8.x

Cause

There is a problem with the agent from running properly or a configuration change is requiring a restart of the open source telegraf agent.

You may see the following log entry on the agent's messages log

echo '[2025-01-22 21:16:58] [3895265] [INFO] - https://<ops_cloud_proxy_fqdn>//downloads/salt/cloudproxy-http.conf Download completed.'
...
...
...

sed -i -e 's|{{VM_ENTITY_NAME}}|xyz|g' -e 's|{{ARC_SERVER_METRIC_URL}}|https://<ops_cloud_proxy_fqdn>:8443/opensource/default/metric|g' -e 's|{{CERT_PATH}}|/etc/telegraf/telegraf.d/cert.pem|g' -e 's|{{KEY_PATH}}|/etc/telegraf/telegraf.d/key.pem|g' -e 's|{{HTTP_HEADERS}}|vmId = "vm-######"\
vcid = "########-####-####-####-############"\
hostname = "xyz"\
uuid = ""|g' -e 's|{{CMD_PREFIX}}|/bin/bash|g' -e 's|{{MANDATORY_TAGS_PATH}}|\\"/etc/telegraf/telegraf.d/mandatory_tags.sh\\"|g' -e 's|{{TELEGRAF_EXE_PATH}}|\\"/usr/bin/telegraf\\"|g' /etc/telegraf/telegraf.d/cloudproxy-http.conf
 + echo 'Telegraf configuration to post metrics to cloud proxy succeeded. Please restart telegraf.'
Telegraf configuration to post metrics to cloud proxy succeeded. Please restart telegraf.

Resolution

VMware does not support the installation, configuration, or any data quality queries for any Open Source agents. However, we do allow and support the data from them being processed by the cloud proxy. Any queries about the agent should go through the Telegraf open source community. Issues related to Telegraf can be raised through: https://github.com/influxdata/telegraf/issues.

For issues with the open source telegraf agent not running properly, please check the community sources.

If your agent is running without issue, please open a Broadcom Support case describing your issue and add the associated Cloud Proxy logs.

Additional Information