Disk Issue in vCenter. Changed the failed HDD. Need help to add the new the HDD to the vSAN.
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Disk Issue in vCenter. Changed the failed HDD. Need help to add the new the HDD to the vSAN.

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Article ID: 391713

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms :

  • The environment shows Failed Disk Issue in vCenter
  • The failed disk has been replaced and new disk is not visible in the vSAN cluster 

Verification steps :

  • In vCenter vSphere UI, vCenter > Host and Cluster View > vSAN cluster > Configure > vSAN > Disk Management, you see a Disk group with a red exclamation diamond and, in the detail window below, it is marked as Absent vSAN Disk.

  • The ESXI host /var/run/log/vobd.log will show below messages 

    YYYY-MM-DDT[time] In(14) vobd[2097812]:  [APDCorrelator] 416559012514us: [vob.storage.apd.start] Device or filesystem with identifier [naa.xxxxxxxxxxxxxxxx] has entered the All Paths Down state.
    YYYY-MM-DDT[time] In(14) vobd[2097812]:  [APDCorrelator] 416565621119us: [esx.problem.storage.apd.start] Device or filesystem with identifier [naa.xxxxxxxxxxxxxxxx] has entered the All Paths Down state.
    YYYY-MM-DDT[time] In(14) vobd[2097812]:  [scsiCorrelator] 416565621462us: [esx.problem.storage.connectivity.lost] Lost connectivity to storage device naa.xxxxxxxxxxxxxxxx. Path vmhba0:C0:T5:L0 is down. Affected datastores: Unknown.
    YYYY-MM-DDT[time] In(14) vobd[2097812]:  [scsiCorrelator] 416559012464us: [vob.scsi.device.state.permanentloss] Device :naa.xxxxxxxxxxxxxxxx has been removed or is permanently inaccessible.
    YYYY-MM-DDT[time] In(14) vobd[2097812]:  [scsiCorrelator] 416565621545us: [esx.problem.scsi.device.state.permanentloss] Device: naa.xxxxxxxxxxxxxxxx has been removed or is permanently inaccessible. Affected datastores (if any): Unknown.
    YYYY-MM-DDT[time] In(14) vobd[2097812]:  [scsiCorrelator] 416560151359us: [vob.scsi.device.state.permanentloss.noopens] Permanently inaccessible device :naa.xxxxxxxxxxxxxxxx has no more open connections. It is now safe to unmount datastores (if any) and delete the device.

Environment

VMware vSAN (All Versions)

 

Cause

This issue occurs due to one or all of these reasons:

  • A physical Disk has failed
  • The physical disk has been removed from server, before removing the disk from vSAN disk group.

Resolution