EEM upgrade fails with the message "Failed to take backup of existing installation".
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EEM upgrade fails with the message "Failed to take backup of existing installation".

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Article ID: 391609

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

Error "Failed to take backup of existing installation" occurs during EEM upgrade attempted directly from   <AutoSys ISO>/modules/EEM/

 

Environment

AutoSys Workload Automation

Cause

  • The message seems to be coming after the installer attempts to stop the services and start
  • CA Directory itechpoz  service would not start. In this specific case, EEM is in a two node HA configuration
  • CA Directory itechpoz on the primary node fails to start
  • There was a file,  itechpoz in the %DXHOME%\pid folder and it was 0 bytes.
  • The presence file  %DXHOME%\pid\itechpoz  was causing CA Directory iTechpoz service not to start. That's the reason why EEM upgrade failed.

Resolution

  • Remove the file %DXHOME%\pid\itechpoz   from the primary EEM server
  • Start the CA Directory itechpoz service
  • Re-run upgrade again